Migration Assistant Listener not working

Hi Everyone,

I’m trying to use Migration Assistant for confluence server to cloud data migration, but facing some issues.

The cloud migration listener is no longer listening to onRegistrationAccepted, onMigrationStarted events.

Earlier the problem was with my cloud site not being whitelisted and it worked fine once the cloud site was whitelisted and now suddenly it no longer listens to the migration events.

Are there any caveats to get this working all the time?

I’m using these

In plugin.xml


In pom.xml


Let me know if any further details are required.



I’ll need to check the logs for the services in use, can you post your appMigrationId that you’re using?


Hi @jrichards,

My Apologies for the delayed response.

Where can i find the appMigrationId? is it the clientKey?



Sorry for the confusion, I thought you were talking about the cloud import side not working. If you’ve upgraded CCMA recently, you’ll need to use a dark feature key to activate the App Migration code.

I would like to point out that the POC code from App Week and the hackathons last year is currently undergoing heavy development and the APIs will change from one day to the next. It isn’t currently supported and it’s very, very likely not going to work completely from end to end.

However, you can try and get it working with

  1. Go to /admin/darkfeatures.action
  2. Scroll down and add migration-assistant.app-migration.feature
  3. Click Submit

If it’s still not working, then it’s likely the code isn’t being registered as a Spring bean and being exported via OSGi. If that’s the case, then roll back whatever changes you’ve made in the Spring configuration or in the pom.xml until it works. OSGi is a bit of a blackhole with debugging, so my advice is to take careful note of what has changed from one day to the next to see what minor tweak might have broken it.

Depending on how you’re installing your plugin, if you’ve running regular Confluence Server (not via atlas-run and atlas-install-plugin) then you can also try cleaning the plugin cache by following the steps in How to clear Confluence plugins cache.

But as a reiteration, this code is still under heavy development and so we don’t recommend at this time developing with it.

Hope this helps.


Also have a look at this post

about signing up for access to the alpha version of App Migrations.


Thanks James, I had signed up for the alpha version of app migration.
Will look into dark feature key and explore more in that direction, However, at this point we have the manual migration path working.

Thanks again for the detailed explanation.