Plugin SDK Skeleton for JIRA Server

Hi there,

still new in jira dev, and I need your help,
can someone can give a full plugin skeleton that I can build with : atlas-mvn package
and that can be upload in jira (7.12+ or 8.0+) without error or waiting for ever that pluggin upload ?
I use atlassian-plugin-sdk-8.0.7
the default skeleton get by : atlas-create-jira-plugin is not good


Hi @yann,

What is the problem you’re having with the default skeleton app?

Hi @pvandevoorde,
What I do for the test (SDK 8.0.7, jira 7.12.3)

atlas-mvn package

after On jira / Manage apps / Upload app / Choose File (myApp.jar) / Upload

And it stay like this for ever on jira

should be easy to reproduce Same result with jira 7.12.3 or jira 8.0.0

if I refresh the Manage Apps, it will show the app installed and working
But I would like the plugin upload finish clean with no error message


1 Like

Are there any error messages in the Jira log files that might give an indication of what happened?

I wish I had some :wink:
I put com.atlassian on DEBUG

and here are the logs
log.css (146.3 KB)

sorry it is a TXT not a CSS …

Version WARM only
Simple-log.css (1.9 KB)

Can confirm, been having this issue with almost every plugin I’ve installed manually by uploading a JAR.

Even though the error shows up the app gets installed just fine and everything works, but the error message is of course annoying and the dialog gets stuck so you have to reload the page.

Happens on Confluence as well.

1 Like

@pvandevoorde did you see the answer that @yann posted? :slight_smile:

Hi @pvandevoorde
Still always very interested to know why I can’t upload a basic app built with the default skeleton

Thanks for the reminder @yann and @sven.schatter.
I’ll bring this to the attention of the right people here in Atlassian.

Hello @yann,

I cannot seem to replicate the issue. I’m using this version based on atlas-version results.

ATLAS Version:    8.0.7
ATLAS Home:       /Applications/Atlassian/atlassian-plugin-sdk-6.3.10
ATLAS Scripts:    /Applications/Atlassian/atlassian-plugin-sdk-6.3.10/bin
ATLAS Maven Home: /Applications/Atlassian/atlassian-plugin-sdk-6.3.10/apache-maven-3.5.4
AMPS Version:     8.0.0

Here are the steps I did:

  1. I built a plugin skeleton like you’ve mentioned, via atlas-create-jira-plugin
  2. Packaged the project by going into the project directory and running atlas-package
  3. Ran a standalone Jira v8.0.0 by calling atlas-run-standalone --product jira --data-version 8.0.0 --version 8.0.0
  4. Upload the app via UPM (v4.0.0.bca9de4189)

So far I do not encounter the errors you experienced. Were there any missteps I took?


Thanks for your test,
here is what I have


ATLAS Version:    8.0.7
ATLAS Home:       C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7
ATLAS Scripts:    C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7\bin
ATLAS Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7\apache-maven-3.5.4
AMPS Version:     8.0.0
Executing: "C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7\apache-maven-3.5.4\bin\mvn.cmd" --version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7\apache-maven-3.5.4/conf/settings.xml
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-18T02:33:14+08:00)
Maven home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.7\apache-maven-3.5.4\bin\..
Java version: 1.8.0_152, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk1.8.0_152\jre
Default locale: en_US, platform encoding: MS950
OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

My pom generated

<?xml version="1.0" encoding="UTF-8"?>

<project xmlns=""


        <name>Example Company</name>

    <description>This is the com.neobards.test8:newTest plugin for Atlassian JIRA.</description>

        <!-- Add dependency on jira-core if you want access to JIRA implementation classes as well as the sanctioned API. -->
        <!-- This is not normally recommended, but may be required eg when migrating a plugin originally developed against JIRA 4.x -->





        <!-- Uncomment to use TestKit in your project. Details at -->
        <!-- You can read more about TestKit at -->

                    <!-- Uncomment to install TestKit backdoor in JIRA. -->

                    <!-- See here for an explanation of default instructions: -->
                    <!-- -->

                        <!-- Add package to export here -->

                        <!-- Add package import here -->

                        <!-- Ensure plugin is spring powered -->


        <!-- This property ensures consistency between the key in atlassian-plugin.xml and the OSGi bundle's key. -->
        <!-- TestKit version 6.x for JIRA 6.x -->


and here is my UPM

Installed version: 4.0.0-bca9de4189
Available version: 4.0.4
Vendor: [Atlassian](

I upload it on my production test serveur jira 8.1
here is the jar, sorry for hack (put .css for upload)
newTest-1.0.4-SNAPSHOT.jar.css (264.6 KB)

generated by ‘atlas-package’

Thanks for the JAR file. I tried installing it in my standalone instance and I was able to install it successfully (see screen recording here). Other than our OS, not sure what else is different in our setup.

How did you spin up your Jira instance?


I think the issue you might be seeing is related to a bug in the latest version of the Atlassian Plugin SDK. There’s a known problem with the ‘atlas-mvn’ command. Other commands such as atlas-run work without problems using the JIRA plugin skeleton.

You’ll find a workaround described on the JIRA issue.


My jira instance is a clone of my production server, on ubuntu 16.04 LTS, and my client is under windows 10
as I see you are on Mac, I make differant test :
chrome ==> FAIL
firefox ==> OK
Edge ==> OK

So there is a problem with the UPM under chrome (Version 74.0.3729.131 (Official Build) (64-bit))

Thanks for the additional investigation. I’ve upgraded my Chrome from v73.xx to Version 74.0.3729.131 (Official Build) (64-bit) and the results are still successful. I also tried enabling and disabling the cache but still works for me. This is interesting and a tricky one :slight_smile:

I have found the problem
I remove the add blocker named : ghostery
now it works fine …

sorry for this, it was the add blocker in the end, it was working fine few month ago …
Thanks for helping

1 Like

Ah ha! Ad blockers :slight_smile: Glad you were able to drill it down to a specific browser and got it resolved.


You help me well to search in the good direction
thanks again