Problem triggering Openshift build from Bitbucket when Code is Merged

Hi,

I am trying to trigger a new build inside OpenShift when a pull-request is “merged” on the Bitbucket.
I am using using “pull request notifications” plugin and trying to POST to the “Generic Webhook” endpoint defined inside the buildconfig of the corresponding repository. Bitbucket give me 500 and tells me to look at the server logs but when I loging to bitbucket server and check the logs I see nothing. Not even a new log is being generated. Plus, I can actually trigger the Generic Webhook endpoint inside OpenShift using “curl -X post” to the endpoint url.

Tried this: https://marketplace.atlassian.com/plugins/com.atlassian.stash.plugin.stash-web-post-receive-hooks-plugin/server/overview?_ga=2.78480023.2040945156.1510125323-1551904994.1507097572 not working

Also tried: /plugins/nl.topicus.bitbucket.bitbucket-webhooks/server/overview not working

Any ideas?

Note: Since Bitbucket seems to not support this, I though why not write my own plugin. Then there is another problem there. -> Com.atlassian.plugin:atlassian-spring-scanner-maven-plugin:2.1.3 not found

EDIT: Apparently we have an older version of Bitbucket server installation. Support says upgrading to the latest version will solve my problem because webhooks are a part of Bitbucket server now.