Retiring IE11 support for Atlassian cloud, server, and data center products

In 2015 Microsoft released Edge as the browser to supersede Internet Explorer (IE). Since then IE has not received major updates, or added support for many modern web standards. Microsoft recently discouraged the use of Internet Explorer as a default browser, and we’ve also seen a decrease in IE11 usage across our cloud, server, and data center products over time.

To allow us to continue to take advantage of modern web standards to deliver improved functionality and the best possible user experience across all of our products, we have decided to end support for IE11.

What does end of support for IE11 mean?

End of support means we will not fix bugs that are specific to IE11, and will begin to introduce features that aren’t compatible with this browser.

When is this happening?

  • For all Atlassian cloud products, support will end on 31 March 2020.
  • For Atlassian server and data center products, the last version to support IE11 will be released between September 2019 and March 2020. Subsequent versions will not support IE11. We’ll provide plenty of information about this in the upgrade notes for each version. Please see the table below for confirmed versions.
Server and data center product Last IE11-supported version End-of-support dates
Jira Software 8.5 (Enterprise Release) TBC (version is yet to be released)
Jira Service Desk 4.5 (Enterprise Release) TBC (version is yet to be released)
Confluence 7.x (Enterprise Release) TBC (version is yet to be released)
Bitbucket 6.x TBC (version is yet to be released)
Crowd TBC TBC (version is yet to be released)
Bamboo 6.10 17 September 2021
Fisheye 4.8 TBC (version is yet to be released)
Crucible 4.8 TBC (version is yet to be released)
  • For Atlassian cloud, server, and data center apps such as Portfolio for Jira, Questions for Confluence, and Team Calendars for Confluence, apps will continue to support IE11 until 31 March 2020 (cloud apps), or until the last version of Jira or Confluence that supports IE11 has reached end of life (server and data center apps).

What this means for you

Your app should continue to be compatible with IE11 (i.e. no loss of functionality, critical IE11-related bugs should be fixed) until the following timeframes:

  • For apps in Atlassian cloud products: until March 31, 2020
  • For apps in Atlassian server or data center products: until the last server or data center product that supports IE11 has reached end-of-life.

We will continue to update the table above as we confirm the last IE11 supported versions of our server and data center products and welcome any questions or feedback.

Thanks,

The Atlassian team

14 Likes

:dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing::dancer::dancing_women::dancing_men::man_dancing:

5 Likes

Confluence 7.0 was just released, supports IE11 and is an Enterprise version so it will be supported for 2 years. So, as I understand, IE11 will still be supported for 2 years in this example, is it correct?

Does this mean you’ll start supporting Edge for Confluence Cloud? According to https://confluence.atlassian.com/cloud/supported-browsers-744721663.html only Jira products are supported for edge. Currently my organisation only has IE and Edge in their SOE.
Thanks!

Does this mean you’ll start supporting Edge for Confluence Cloud?

Yup!

According to https://confluence.atlassian.com/cloud/supported-browsers-744721663.html

Apologies for the confusion. We will be updating that docs page really really soon.

Confluence 7.0 was just released, supports IE11

Yup, we did not introduce any features that are incompatible with IE11 in Confluence 7.0.

and is an Enterprise version so it will be supported for 2 years. So, as I understand, IE11 will still be supported for 2 years in this example, is it correct?

Not quite correct.

Yes, Enterprise Releases will receive bug fix updates throughout its two-year support window. But no, Confluence 7.0 is not an Enterprise Release.

The upcoming Confluence Enterprise Release (i.e. version 7.x, TBC what exact number ‘x’ is) will be the last IE11-supported version and will support IE11 for two years.

Older feature releases would no longer receive bug fix updates, as we focus on updating the latest feature release.

You can learn more about Enterprise Releases here.

3 Likes

Like everyone else I’m sure, this is a relief.

But P2 vendors still need to support IE for at least another 2 years. IMHO Atlassian should have been a bit more courageous and dropped support several years ago, in line with companies like github.

3 Likes

Hi,

I guess Atlaskit is affected by this as well?

BR - Martin

Yup. IE11 support for Atlaskit will end on 31 March 2020, in line with our cloud products.