Supported propertyKey patterns

I’m trying to convert an existing app to use the jira:entityProperty module. I’m getting the following error

21:6    error    jira:entityProperty property propertyKey 'company.supportcases' should match pattern "^[a-zA-Z0-9-_]

Is ‘.’ a supported character? I have successfully created Jira issue entity properties where the key name contains a ‘.’ so it seems strange that the Forge module does not support this character.

Here’s the relevant section from my manifest

jira:entityProperty:
    - key: "company-support-cases-entity-property"
      entityType: "issue"
      propertyKey: company.supportcases
      values:
        - path: Count
          type: number
          searchAlias: numberOfSupportCases

The app currently uses the connect module jira:jiraEntityProperties where a ‘,’ character is supported in the key name. Here’s the working manifest snippet

      keyConfigurations:
        - propertyKey: company.supportcases
          extractions:
            - objectName: Count
              type: number
              alias: numberOfSupportCases

Steve.

1 Like

Supporting this as I have found it valuable to “scope” the entity properties in some way like com.company.appname for example. When you look through them with the entity property tool it becomes quite messy otherwise.

I think this would also block us from migrating Connect to Forge

Hi @SteveYoungs, @ernst.stefan.

It is an oversight on our side - I’m creating issue with high priority in our backlog and will let you know as soon as it will be fixed.

Sorry for any inconvenience.
Best regards,
Łukasz

1 Like

Hi @ljarzabek
Thanks for the quick attention. Will this also resolve a similar problem I reported last year - onJiraIssue fails if key contains a period

Thanks
Steve

Hi @SteveYoungs,

The nature of the problem seems to be similar (allowing . character) but it’s different part of the API. Unfortunately, our fix won’t resolve it. I will try to contact with responsible team but I cannot commit to any date.
Sorry for any inconvenience.

Best regards,
Łukasz

Hi @SteveYoungs, @ernst.stefan,

You can now use . character in propertyKey. Please use --no-verify flag when you will do forge deploy. Support in Forge CLI will be added with next Forge release (--no-verify won’t be longer needed) but we wanted to unblock you as soon as possible.

Best regards,
Łukasz

1 Like

Hi @ljarzabek ,
I just wanted to confirm that with Forge CLI 4.3.1 this is now working as expected - no requirement to use the --no-verify flag!

Thanks
Steve

1 Like