Unable to distribute 3lo App

I raised a ticket in the Developer Service Desk to distribute my 3LO app public. The service desk request got approved but when I turn the ‘Make app public’ switch on and try to ‘Save changes’, this popup appears.

Screenshot 2020-07-21 at 3.50.58 PM

The privacy policy link provided is a valid link to a publicly available page.

Am I missing anything here? How do I fix this?

Hi, I just tried this with my personal account and it worked just fine.

Do you mind posting all of the details that you are attempting to put in the Distribute Tab here? That way we can validate that they are public?

Otherwise, if you don’t want to do that, can you please post the x-b3-traceid HTTP Header from the https://developer.atlassian.com/graphql HTTP request that is fired when you hit the “Save Changes” button so that we can see what error you are getting back? Cheers.

The x-b3-traceid is 48a0bda73aad547d

Hi @AkshayMenon, sorry for taking it so long to respond, we were finding the root cause of your issue and we believe we found something. Could you please share the service desk DEVHELP issue key? That would help us a lot.