Status 200 when running connect app locally

I’m suddenly encountering an error when I run my connect app locally.
The error is:

Failed to register with host (200)
The app "agile-docs" could not be installed as a local app as it has previously been
installed from Atlassian Marketplace

This error has only just started occurring.
It happens even after I uninstall the add on from my jira instance.
Any ideas?


Hi @RhysDiab

This is introduced recently and we are going to announce in next few days. This change has been put in place to prevent any user confusion between locally installed apps and apps installed from Atlassian Marketplace.

To resolve this, you will now need to use a separate instance to undertake testing with a local version of your app.



Thanks for the response @aagrawal2. Much appreciated.

Is there a way to use my current instance for local development and set up another for production testing?

I have lots of project styles and structures set up on this instance for testing already which would take some time to port to another instance. And as I understand it, I only get one free development instance for testing?


Hi @RhysDiab,

Is there a way to use my current instance for local development and set up another for production testing?

I think there’s no easy way around this. Once you’ve had a marketplace version installed on your instance, even uninstalling it and installing the local version would result in the same error. You can rename the appKey but I’m sure that’s not desirable.

And as I understand it, I only get one free development instance for testing?

Afaict, you can get as much dev instance as you want. Just sign up in



Thanks for the response @acalantog

1 Like

Anytime @RhysDiab Enjoy your Connect development journey :slight_smile:

1 Like

Hi @acalantog and @aagrawal2, this is an unfortunate change. We have spent a considerable amount of time building out a cloud demo instance and at some point we must have also installed our app from the marketplace.

Now we are unable to swap this instance over to our development build/servers, which means we can’t continue to build out our documentation on the same issues or easily run demonstrations on upcoming features for our customers using realistic data. Our developers also have some large test instances that will need to be rebuilt.

Can we submit a support ticket to marketplace and have you change whatever setting is stored against particular instances so we can continue to use our own dev servers?

Otherwise we have a very big task to recreate these instances and issues, and an ongoing risk that at some point someone will stuff up and accidentally install a marketplace licence and hose our demonstration instances again.


That means we need two access tokens now in order to run our local app and a cloud version of our app on two cloud instances. For a sync tool like Backbone Issue Sync where I’m working for this already means four access tokens per developer, because we need to test our sync use case always with two instances. Would it then be possible to at least increase the number of access tokens available per app (currently 50), so we don’t run into problems there? We haven’t reached the limit yet, but are also not too far away and with a growing team and this recent change it will become an interesting situation :slight_smile:

1 Like

Hey. This is really painful for us as app developers.
It is a big limitation not only for our development process but also for debugging issues with customers. We also used that option to debug issues in production.

I really don’t understand why are you limiting us like this!? The option should be available as long as I
enabled the development mode. Can you put it back?



I haven’t tried it, but would a solution be to use a different addon-key for development? That way you could install from marketplace and dev into the same instance, swapping would be an uninstall/install dance.

Like the change, understand the need for the change - but don’t like how it was rolled out (no change notice) and how it restricts us from debugging our staging environment. (There are times when we have a staging instance being used by an instance and then have to temporarily install a local version so that we can debug what’s actually happening with the data).

1 Like

Hi everyone,

You can continue following up on this topic at Change notice - Changes to installation of a local app on Atlassian Cloud products. We will continue to answer your questions there.


Hi @jmort,

That should work! :+1:

I just had a problem that on one of our test sites our app was automatically reinstalled from the Marketplace and now we cannot reinstall it manually. And the workaround with a different addon key does not work because we are requesting the ACCESS_EMAIL_ADDRESSES scope which is approved only for our production app key. /cc @jmort


@acalantog As a followup to this, can you make a new release of ACE? With the recent merge of we could use the appKey variable in atlassian-connect.json. :smiley:

@acalantog @aagrawal2 @nmansilla

Is ACE ready for a new release? The appKey feature would be a great addition ( )

1 Like

I am suddenly seeing this error on my instance that was only ever installed via the market place, it wont allow me to update to new version. Something seems amiss.

I really don’t get the point.
Nobody randomly install local apps. It is only developers or development team that need to do this and they know what they are doing.
I have a lot of data on one instance and I need to test compatibility before releasing a new version. Now I have to set up a new instance and all my data is not available on the new instance.
This is an unfortunate and annoying limitation. Please revert back to what works.